2.1.8.9

We’re please to announce version 2.1.8.9, which contains several important updates for compatibility with WordPress 4.5 through 4.5.2.

First, WordPress’ continued focus on security and reliability on their backend processes started generating automatic emails on profile updates. Since Presspoint primarily manages user profiles, it was imperative that we block automatic notices from going out. As we continue to watch these changes with WordPress we will begin building out options to support these at the discretion of site administrators.

Second, we rewrote significant portions of the Forms API to ensure that required fields are correctly scoped. Prior to the version 2.1.8 series there were possible instances where certain required fields (especially the taxonomy multiselect option) might not correctly prevent submissions.

Third, we updated the password reset protocols in Presspoint to be even more reliable and user-friendly. Now, password resets are sent with multiple urls as an HTML email to preserve your site’s branding.

Finally, 2.1.8.9 contains approximately 30 other bug fixes and small updates that are designed to improve the overall system.

And last… while these updates may seem small, they are indicative of far more substantial updates that will be announced very soon. We can’t say too much now but we’re going to be making a huge leap forward pretty soon and we can promise you, Presspoint is going to be better than ever in 2016.

Thank you, as always, for being a subscriber!

Cancel