,

Forgive the subject line but we wanted you to know that it is very important that you upgrade to the latest version of Presspoint as soon as possible. It is even more important if you are running the latest version of WordPress 4.4.1.

The reason for this is that in the last major release for WordPress 4.4 new security protocols were implemented designed to make WordPress safer, which is generally good. However, it has impacted some of Presspoint’s protocols and our latest release 2.1.8.3 resolves those impacts.

It is possible that, if left to chance, data loss may occur so it is advisable that you update as soon as you are able. It is not always consistent or predictable, however, the controls we have implemented with this latest release provide for that. Due to the nature of the WordPress changes we are continuing to do full audits of the system and will continue to provide updates as soon as we discover any new developments.

If you have any questions, please file a support ticket on presspointcrm.com and we will be happy to answer them as soon as possible.

Best,

Frank Neville-Hamilton

Cancel